记一次 React Native 大版本升级过程——从0.40到0.59

react native 去年把公司几个react native 相关的项目升级了下,已经过去一段时间了,这里系统整理下之前的整个过程。 背景 之前到公司的时候发现公司用的还是0.40的版本,据了解,当时项目做的比较早,导航用的是自带的路由库,状态管理用的是 mobx。到公司之前虽然有react native的相关经验,不过当时官方已经推荐用 react-navigation 替代原来的导航库。以前的项目比较小,也没用到状态管理,react-nati...

React Native 报错汇总(不断更新中2020年6月22日)

错误1:SyntaxError:Strict mode does not allow function declaration in a lexically nested statement.   解决办法: 打开下面的文件 node_modules\react-native\Libraries\Core\InitializeCore.js  如果没有,执行 npm install 修改代码 function handleError(e, isFatal)为var handleError = function(e, isFatal)  如下图所示:      错误2 com.android.builder.testing.api.DeviceException: c...